Limited access issues for select US users

Incident Report for GWI

Resolved

A client who was impacted by this issue has confirmed that it has now been resolved.
Posted Mar 10, 2026 - 18:27 UTC

Monitoring

We have deployed a fix that appears to have resolved the issue. We are continuing to monitor the platform to ensure stability.
Posted Mar 10, 2026 - 10:22 UTC

Investigating

We're investigating reports of a limited number of users in the US being unable to access our platform
Posted Mar 10, 2026 - 09:15 UTC
This incident affected: Authentication / SSO.